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Banner Terminology 
 
Form - A form is an online document where you can enter and look up information in your 
database. A form visually organizes information so it is easier to enter and read. A Banner form 
is similar to a paper form, except information is entered once and then used by other forms, 
reports, and jobs.  Forms can include windows, window panes, dialog boxes, and alert boxes. 
 
Parts of a Form 
The following figure shows a sample form. Each part of the form is described on the 
following pages. 
 
 
menu bar 
     toolbar 
 
title bar 
 
key block 
 
 
 
 
 
 
 
 
 
 
 
other blocks 
 
 
 
 
 
 
 
 
 
 
 
auto hint 
 
status line 
 
Menu Bar - The Banner menu bar, located at the top of every form, contains pull-down menus. 
You can access an option in a pull-down menu at any time, except when you are in a dialog box, 
alert box, or List of Values (LOV). (You must respond to these windows before you can access a 
pull-down menu.) 
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Toolbars - The Banner toolbar contains buttons that perform common functions. It is located 
directly under the menu bar. When you move your cursor over a button and pause, a tool tip 
appears with text that describes the function of the button. 
 
 
 
 
Title Bar - The title bar shows the following information: 
• Descriptive form name 
• Form name (seven or eight characters) 
• Release number 
• Database name from the Installation Control Form (GUAINST) 
 
Blocks - A block is a section of a form or window that contains related information. If a form or 
window contains more than one block, each block (except the key block) may be enclosed in a 
beveled box. 
 
Most blocks have a title. There are three exceptions: 
 
• A key block does not have a title. 
• If a form or window has only one block, the block does not have a title. 
• If a form has a key block and only one other block, the second block does not have a title. 
 
Key Block - The first block on most forms contains key information. (Some forms, especially 
validation forms and certain list forms, do not have a key block.) The key block determines what 
is entered or displayed on the rest of the form. All information on the form refers to the key 
block.  The key block has at least one field and sometimes more. 
 
Other Blocks - Other blocks contain additional details for the key information. Each block 
contains related information and is usually enclosed in a beveled box. 
 
Auto Hint 
The auto hint at the bottom of the form can contain the following information for the field where 
the cursor is located: 
 
• Brief field description 
• Error and processing messages 
• Keyboard equivalents, if you can access other blocks, windows, or forms from the field 
 
Status Line 
The status line directly under the auto hint can contain one or more of the following messages: 
 
Record n/n Shows the number of the current record followed by the total number of records in 
the current block. If there are more records than fit in the window, the total appears as a question 
mark (for example, 3/?) until you scroll to the last record in the block. Once the last record is 
displayed, the total appears as a number (for example, 3/15). 
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List of Values Indicates the field has a List of Values 
 
Enter Query Indicates the form is in query mode. 
 
 
 
 
Elements on a Form 
 
Fields - Fields are areas on a form where you can enter, query, change, and display specific 
information. A field is sometimes called an item. 
 
Records, Rows, and Columns - A record is a set of related fields. For example, a street, 
city, state, and ZIP/postal code form an address record. 
 
If a block has multiple records, the records often appear in rows and columns. A horizontal scroll 
bar appears under the columns if all columns don’t fit into the window at once. A vertical scroll 
bar appears on the right side of the rows if all rows don’t fit into the window at once. When you 
select a row, the entire record is highlighted to identify it as the current record. 
 
Pull-Down Lists - Pull-down lists are used to select a field value from a list of pre-defined 
values. A down arrow in the right side of the field indicates the field has a pull-down list. 
 
Note: Fields with a Search button have a similar-looking down arrow. Pull-down lists have the 
arrow inside the field, while the Search button is located outside the field. 
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Displayed Form Names 
 

 
 
You can choose whether form names are displayed in the following places: 
 
• Options pull-down menu 
 
• Navigation frame (client/server environments only) 
 
• Left pane of menu maintenance forms 
 
If you choose to display form names in the navigation frame, the name appears as a bubble help 
when you move the cursor over the navigation option. 
 
To display or hide form names: 
 
1. Access the General User Preferences Maintenance Form (GUAUPRF). 
 
2. Click the Form Display Options button. 
 
3. Select an option from the Form Name Display Option pull-down list. 
 
4. Select the OK button. A dialog box says the change has been applied. 
 
5. Select the OK button in the dialog box. 
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Default Expanded Menu 
 

 
 
The SCT Banner main menu appears when you first access Banner. You can change 
the default product menu that is expanded to suit your personal preference. 
 
To specify the default expanded menu: 
 
1. Access the General User Preference Maintenance Form (GUAUPRF). 
 
2. Choose the Menu Options tab. 
 
3. In the User Default field, enter the name of the menu that you want as the 
default, or click the Search button to search for it using the Object Search Form 
(GUIOBJS). 
 
4. Save your changes. 
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Getting Around In Banner 
 
Banner provides numerous ways to navigate through the system: 
 
Main menu   

• You can select from a list of the menus, forms, jobs, and QuickFlows in Banner. 
 

 
 
Direct Access   

• You can access a menu, form, job, or QuickFlow by its name. 
 

 
 
Object Search   

• You can access a form, job, or QuickFlow if you know part of its name, description, or 
type. 
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Site map    
• You can view a list of the top-level menus and one level below them. 

 

 
Tabs     

• You can access windows on tabbed forms by selecting the tab. 
 

 
 
Options menu   

• You can access other forms, windows, and blocks related to the current form, window, 
and block. 

 

 
 

Option list    
• You can right-click on a form anywhere outside a field to display the Option list, from 

which you can perform functions, navigate to other parts of the form, or add the form to 
your personal menu. 

 
Buttons    

• You can access another form or window related to the current record or field. 
 

 
 

Mouse    
• You can click an iconic button, field, record, block, or window that is currently 

displayed. 
 
Keyboard equivalents  

• You can use the keyboard to access a form, window, block, or field. 
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QuickFlow    
• You can automatically access forms that are linked in a chain. 

 

 
 

Last 10 forms in the File pull-down menu  
• You can quickly re-access a form that was previously opened in the current session. 

 

 
 
 
Display Navigation Window key  

• You can press this key on any form to display a navigation window that enables you to 
enter the name of another form or job and navigate to it. 
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Keyboard Navigation 
 
 

BANNER:  Field => Record => Block => Form 
FUNCTION   FUNCTION  
Next Field Tab  Next Block Cntl-PgDown 
Previous Field Shft-tab  Previous Block Cntl-PgUp 
Clear Field Cntl-U  Clear Block Shft-F5 
     
Next Record Down Arrow  Scroll Up Up Arrow 
Previous Record Up Arrow  Scroll Down Down Arrow 
     
Enter Query F7  Copy F6 
Execute Query F8  Replace F4 
     
Show Keys Cntl-F1    
Commit/Save F-10    
Get List F-9    
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Optional Keystrokes for Banner 
 
 

KEY Esc Tab F1 F2 F3 F4 F5 F6 F7 F8 F9 F10 

 Cancel Next 
Field 

Help  Duplicate 
Field/Item 

Duplicate Record Insert 
New 

Record 

Enter 
Query 

Execute 
Query 

Search 
(LOV) 

Save 

Shift  Previous 
Field 

Display 
Error 

Count 
Query 
Hits 

Exit with 
Value 

Clear 
Record 

Clear 
Block 

Remove 
Record 

Clear 
Form & 
Rollback 

Print   

Ctrl  Next 
Field 

Show 
Keys 

         

 
KEY Page up Page 

Down 
Up Arrow Down 

Arrow 
Left 

Arrow 
Right 
Arrow 

Q U Space Bar in Check 
Box Fld 

Left Mouse Double 
Click 

   Previous 
Record 

Next 
Record 

Prev. 
Radio 
Button 

Next Radio Button  Toggle On / Off On date 
field=calendar On 

Amount 
field=calculator 

Shift           Dynamic 
Help 

 

Ctrl Previous 
Block 

Next 
Block 

    Exit or 
Cancel 

Clear 
Field 
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Function Icon Key Stroke 
Save 

 

F10 

Rollback 
 

Shift F7 

Select 
 

Shift F3 

Insert Record 

 

F6 

Remove Record 
 

Shift F6 

Previous Record 
 

Up Arrow 
or Page Up 

Next Record 
 

Down Arrow 
or Page Down 

Previous Block 
 

Ctrl Pg Up 

Function Icon Key Stroke 
Next Block 

 
Ctrl Pg Dn 

Enter Query 
 

F7 

Execute Query 
  

F8 

Cancel Query 
 

Ctrl Q 

Print 
 

Shift F8 

Online Help 
 

 

Exit 
 

Ctrl Q 
Alt F4 

Search 

 

F9 
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Wildcard Characters 
 

• Any number of characters before or after known information:  ‘%’ 
o Ex. – ‘CA% will result in CASH, CAT, CANINE, CALIFORNIA, etc. 

 
 

• One Character within known information:   ‘_’   
o ex. – ‘C_T’  will result in CAT, CUT, COT, etc.
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Naming Conventions 
 

Naming Conventions 
 

 All Banner objects adhere to naming conventions 
   e.g., forms, tables, processes 

refer to chapter one of the technical reference manuals 
 

Form, process, and table naming 
 

The names of all Banner forms (except menu forms), reports, processes, and 
tables are seven characters long and have this structure: 

 
Example                    F O A I D E N 
                 - - - - - - - 
Position Locations     1 2 3 4 5 6 7 

 

Position Location 1 
 

Identifies the primary system owning the form, report, process, or table. 
 

A - Alumni/Development    S - Student 
R - Financial Aid     T - Accounts Receivable 
 F – Finance      V - Voice Response 
G – General      H - New Products (Web) 
N - Position Control     P - Human Resources/ Payroll/ 
Personnel 
W Y Z  - Reserved for client-developed 
new applications built to co-exist with 
Banner applications 
 

General Position Location 2 
 
Identifies the module owning the form, process, or table. 
If Position 1 is F, the character in Position 2 is: 
 
A - Accounts Payable   R - Research Accounting 
B - Budget Develop.    S - Stores Inventory 
E - Event Management   T - Validation Form/Table 
F - Fixed Assets    U – Utility 
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G- General     W Y Z - Reserved for client 
J - Job Submission    developed forms or modules 
L - Letter Generation   used within a Banner application 
 O – Overall                                   (character in position 1 not = W,Y, Z) 
P – Purchasing 
 
General Position Location 3 
 
Identifies the type of form, report, process, or table. 
 
A – Application  
B - Base Table (Batch COBOL Process) 
I - Inquiry Form 
O - Online COBOL Process 
M-Maintenance 
Q - Query Form accessed from another form 
R - Rule Table, Repeating Table, Report or Process 
T - General Maintenance Test Pattern 
V - Validation Table or View 
 
Positions 4, 5, 6, 7 
 
Identifies a unique four-character name for the form, report, process, or table 
 
F O A IDEN 
F         Finance 
O         Overall 
A         Application 
 IDEN   Identification   
 
F T M COAS 
F         Finance 
T         Table 
M         Maintenance 
 COAS  Chart of Accounts  
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FRS versus Banner Comparison Table 
 

Information Type 
Banner 
Form 

Subsidiary Ledger (Budget, Revenue, Expense, Transfers) 

FGIBDST 
FGIBAVL 
FRIGITD 
FGIBDSR 

General Ledger (Balance Sheet, Fund Additions/Deductions FGITBAL 
FGITBSR 

Detail Records 
FGIGLAC 
FGITRND 
FGIDOCR 

Document History FOIDOCH 
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Organization Budget Status (FGIBDST) 
 

 
. 
Organization Budget Status Form 
Use the Organization Budget Status Form to view an online query of the budget availability by 
organization code.  Access this form from the General Budget Query Forms Menu (*FINGBUDQ). 
 
Data displays by account code line item for any combination of fund, organization, account, account type, 
program, activity, and location (FOAPAL). 
 
When you execute a query the system queries all records for the full total.  Select Next Set of Records until 
you see a Last Row of Record Queried message. 
 
 

STEP ACTION 
1 Select a Chart “COAS” *Required Field* 
2 Select a Fiscal Year *Required Field* 
3 Select the desired combination FOAPAL 
4 Determine (Click) wether to include revenue accounts 
5 Perform a Next Block function. 
6 Review detail or further refine query 

 
Note: Use the Options menu to access additional query forms supporting the detail on this 
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Grant Inception to Date (FGIBAVL) 
 

 
 
Budget Availability Status Form 
This form allows the user to query on-line the status of the organization’s accounts for 
transaction processing. The form provides current information (all completed transactions 
not necessarily posted) for Adjusted Budget, Year-to-Date Activity, Budget 
Commitments and Available Balance for selected Index, funds, organization, account and 
program combinations. Does not display Activity or Location information. Requires 
Chart, FY, Fund, Organization and Program and a ‘begins with’ valid operating ledger 
account (data entry level). 
 
 

STEP ACTION 
1 Access the Budget Availability Status Form (FGIBAVL). 

Note: This form will display all activity including in process and not posted transactions. 
 

2 Enter the Chart of Accounts that you want to query in the Chart field. 
Note: This should default from the user profile *Required Field* 
 

3 Enter the fiscal year that you want to query in the Fiscal Year field. *Required Field* 
 

4 Enter the index code that you want to query in the Index field. 
Note: This will default certain pieces of the FOAPAL. This is optional. 
 

5 Enter the fund code you want to query in the Fund field. *Required Field* 
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6 Enter the organization code you want to query in the Organization field. *Required Field* 

 
7 Enter the account code you want to query in the Account field. *Required Field* 

 
8 Enter the program code you want to query in the Program field. 

 
9 Select the type of encumbrances to review (Both, Uncommitted, or Committed) in the 

Commit type field. 
 

10 Perform a Next Block function. 
 

11 Review detail or further refine query 
 

12 Click the Exit icon. 
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Grant Inception to Date (FRIGITD) 
 

 
 
 
Grant Inception to Date Form 
The Grant Inception to Date Form (FRIGITD) is used to retrieve account or account type 
information including adjusted budget, inception-to-date actual activity, encumbrance, and available 
balance information. 
 
 

STEP ACTION 
1 Access the Grant Inception To Date Form (FRIGITD). 
2 Enter the chart of accounts code in the Chart of Accounts field. *Required Field* 
3 Enter the grant code in the Grant field or fund code in the Fund field. *Required Field* 
4 Perform a Next Block function. 
5 Review detail or further refine query 

Optional Enter the beginning month and year of grant activity that you want to query in the Date From 
(MM/YY) field. 

Optional Enter the last month and year of grant activity that you want to query in the Date To (MM/YY) 
field. 

Optional Select the Fund Summary checkbox to view a summary by fund if the grant is linked to 
multiple funds. 

Optional Click the Hierarchy checkbox to view details based on hierarchical values supplied in the Key 
block for query. 

Optional Click the By Sponsor Accounts checkbox to view the activity using the sponsor-defined 
accounts. 
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Optional Click the Include Revenue Accounts checkbox to view the activity for revenue 
accounts for this grant. 
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Executive Summary (FGIBDSR) 
 

 
 
Executive Summary Form 
The Executive Summary Form (FGIBDSR) lets you query for the highest level of the account structure 
hierarchy for adjusted budget, year-to-date activity, budget commitments and available balance for selected 
index, fund, organization, account, program, activity and location combinations. 
• Chart and FY are required 
• FOAPAL selections can be either data or non-data enterable 
• Account Type can be a level 1 or 2 
• Displays only Approved and Posted transactions 
 
 
 
 

STEP ACTION 
1 Access the Executive Summary Form (FGIBDSR).  

 
Note: This form will only show posted transactions. 

2 Enter the Chart of Accounts that you want to query in the Chart field. *Required Field* 
 
Note: This should default from the user profile (FOMPROF). 

3 Enter the fiscal year that you want to query in the Fiscal Year field. *Required Field* 
4 Perform a Next Block function. 
5 Review detail or further refine query 

 
Note: Use the Options menu to access additional query forms supporting the detail on this 
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form. 
Optional Enter the index code that you want to query in the Index field. 

 
Note: This will default certain pieces of the FOAPAL. This is optional. 

Optional Enter the organization you want to query in the Organization field. 
Optional Enter the fund code you want to query in the Fund field. 
Optional Enter the program code you want to query in the Program field. 
Optional Enter the account code you want to query in the Account field. 
Optional Enter the account type you want to query in the Account Type field. 
Optional Enter the activity code you want to query in the Activity field. 
Optional Select the type of encumbrances to review (Both, Uncommitted, or Committed) in the Commit 

Type field. 
Optional Check the Query Specific Account checkbox if you want to query a single account or a single 

account type. 
 
Note: If you check this box, then Account code or Account Type is required. 

Optional Check the Include Revenue checkbox if you want to review information for Revenues. 
 
Note: If you check this box, the total of Budget Availability will be NULL since revenues 
should offset expenses. 
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General Ledger Trial Balance (FGITBAL) 
 

 
 
 
General Ledger Trail Balance Form 
The General Ledger Trail Balance Form (FGITBAL) lets you query the General Ledger account balances 
for selected funds, account types, and account code combinations. 
• Chart, FY and Fund are required 
• Funds must be data enterable 
• Account types can be both level 1 and 2 
• Account code must be data enterable 
• Account code queries only that code 
 
 

STEP ACTION 
1 Access the General Ledger Trial Balance Form (FGITBAL). 

 
Note: This form will only display posted transaction. 

2 Enter the Chart of Accounts that you want to query in the Chart field. *Required Field* 
 
Note: This should default from the user profile (FOMPROF). 

3 Enter the fiscal year that you want to query in the Fiscal Year field. *Required Field* 
4 Enter the fund code you want to query in the Fund field. *Required Field* 
5 Perform a Next Block function. 
6 Review detail or further refine query 

 
Note: Use the Options menu to access additional query forms supporting the detail on this 
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form. 
Optional Enter the account type you want to query in the Account Type field. 
Optional Enter the account code you want to query in the Account field. 
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Trial Balance Summary (FGITBSR) 
 

 
 
Trial Balance Summary Form 
The Trial Balance Summary Form (FGITBSR) lets you query the General Ledger account balances for 
selected funds, account types, and account code combinations. This enables viewing of values at higher 
levels within the Fund hierarchy. 
• Chart, FY and Fund are required 
• Fund can be either data or non-data enterable 
• Fund type can be level 1 or 2 
• Account type can be level 2 or 2 
 

STEP ACTION 
1 Access the Trial Balance Summary Form (FGITBSR). 

 
Note: This form will only display posted transaction. 

2 Enter the Chart of Accounts that you want to query in the Chart field. *Required Field* 
 
Note: This should default from the user profile (FOMPROF). 

3 Enter the fiscal year that you want to query in the Fiscal Year field. *Required Field* 
4 Enter the fund code you want to query in the Fund field. *Required Field* 
5 Perform the Next Block Function 
6 Review detail or further refine query 

 
Note: Use the Options menu to access additional query forms supporting the detail on this 
form. 

Optional Enter the account type you want to query in the Account Type field. 
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Optional Enter the account code you want to query in the Account field. 
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General Ledger Activity (FGIGLAC) 
 

 
 
General Ledger Activity Form 
You can use the General Ledger Activity Form (FGIGLAC) to query the detail transaction activity for 
selected general ledger account combinations. This is for Balance Sheet Accounts only. 
• Chart, FY and Fund are required 
• Fund must be data enterable 
• Account (optional) must be data enterable 
 
 
 

STEP ACTION 
1 Access the General Ledger Activity Form (FGIGLAC). 

 
Note: This form will only display posted transaction. 

2 Enter the Chart of Accounts that you want to query in the Chart field. *Required Field* 
 
Note: This should default from the user profile (FOMPROF). 

3 Enter the fiscal year you want to query in the Fiscal Year field. *Required Field* 
4 Enter the fund code you want to query in the Fund field. *Required Field* 
5 Perform the Next Block function. 
6 Perform a Query Execute to retrieve data. 
7 Review detail or further refine query 

 
Note: Use the Options menu to access additional query forms supporting the detail on this 
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form 
Optional Enter the fiscal period that you want to query in the Period field. 
Optional Enter the account code you want to query in the Account field. 
Optional Enter the Index code you want to query in the Index field. 
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Detail Transaction Activity (FGITRND) 
 

 
 
Detail Transaction Activity Form 
You can use the Detail Transaction Activity Form (FGITRND) to query the detailed transaction activity for 
selected operating ledger account combinations. This is for Operating Accounts only. 
 
 

STEP ACTION 
1 Access the Detail Transaction Activity Form (FGITRND). 

 
Note: This form will only display posted transactions. 

2 Enter the Chart of Accounts that you want to query in the Chart field. *Required Field* 
 
Note: This should default from the user profile (FOMPROF) 

3 Enter the fiscal year that you want to query in the Fiscal Year field. *Required Field* 
4 Perform the Next Block function. 
5 Perform a Query Execute to retrieve data. 
6 Review detail or further refine query 

 
Note: Use the Options menu to access additional query forms supporting the detail on this 
form 

Optional Enter the index code that you want to query in the Index field. 
Note: This will default certain pieces of the FOAPAL. This is optional. 

Optional Enter the fund code you want to query in the Fund field. 
Optional Enter the organization you want to query in the Organization field. 

Optional Enter the account code you want to query in the Account field. 
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Optional Enter the program code you want to query in the Program field. 
 

Optional Enter the activity code you want to query in the Activity field. 
Optional Enter the location code you want to query in the Location field. 
Optional Enter an ‘S’ in the Query Type field to query a specific account. 

Note: When selecting a specific account, the Account must be entered. Banner will 
populate an ‘R’ for all accounts if nothing is entered. 

Optional Enter the type of encumbrances to review Null (for Both), ‘U’ for Uncommitted, or ‘C’ for 
Committed) in the Commit Type field. 
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Document Retrieval Inquiry (FGIDOCR) 
 

 
 
Document Retrieval Inquiry Form 
Use the Document Retrieval Inquiry Form (FGIDOCR) to query any posted document. 
 

STEP ACTION 
1 Access the Document Retrieval Inquiry Form (FGIDOCR). 

 
Note: This form will only display posted transactions. 

2 Enter a valid document number in the Document field. *Required Field* 
3 The Submission Number field will display the submission number associated with the 

document. 
 
Note: Banner will update this field. 

4 The Document Type field will populate with the document type associated with the 
transaction. 

5 Perform a Next Block function. 
6 Review detail or further refine query 

 
Note: Use the Options menu to access additional query forms supporting the detail on this 
form 
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Document History (FOIDOCH) 
 
 

 
 
Document History Inquiry Form 
Use the Document History Inquiry Form (FOIDOCH) to query any posted document 
related to Requisitions, Bids, Purchase Orders, Issues, Invoices, Checks, Returns, 
Receiving Documents, Asset Tags, and Asset Adjustments. 
 
 

STEP ACTION 
1 Access the Document History Inquiry Form (FOIDOCH). 

 
Note: This form will only display posted transactions. 

2 Enter a valid document type in the Document Type field. *Required Field* 
 
Note: Use the Down Arrow Button to access a list of valid values. 

3 Enter a valid document number in the Document Code field. *Required Field* 
 
Note: Use the Down Arrow Button to access a list of valid values. 

4 Perform a Next Block function. 
5 Highlight the document number in the detail block you wish to view. 
6 Use the Options Menu to select corresponding document detail information 
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